Halloween Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I bought a 400 watt fogger from Michaels and need a timer. I bought what I thought would be a compatible one from Target. The timer will run the fogger in manual mode, but the fogger won't run on the timer setting. I monitored it for about 10 minutes and it never went! I want to buy the timer local if I can, since buying a gemmy timer online is about $30 shipped right now and is more than I paid for the fogger. I live in Salt Lake City if anyone knows of a location. Is this timer defective or incompatible with my fogger?
 

·
Registered
Joined
·
223 Posts
I bought the same fogger from michaels, and the timer I have looks like the same one as the one target is selling, and it works just fine. Although, thats just from a visual comparison. You might have a bad timer. You could buy the one from spirit with the 20% off coupon, and get it for around $12. But I couldnt say if it would work with it or not, sorry.

On a side note. Target has those timers on sale with free shipping right now for only $7.99. But they are backordered. They have a delivery date of Oct. 27th thru Nov. 13th I believe. So you might get it before Halloween, but if not you have it for next year.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
I have -visually- the same timer as is found on Spirit. Does the gemmy fogger need more than 10 second cycles? Any way to test my timer?
 

·
Registered
Joined
·
223 Posts
Well I was just at Target, and they had some of the timers there for the same price $7.99 so I got one, and I will try it with my fogger also. Ill let you know.
 

·
Registered
Joined
·
223 Posts
Well I picked up three for my brother and I, and all three of them work. It sounds like you have a bad timer mitaccio. Take it back to the store and swap it out.
 

·
Registered
Joined
·
94 Posts
if all else fails, you can either hack the manual switch that came with the fogger so it fires as soon as it heated up and ready or wire it down.

I do that for a couple of my 400w units.
 
1 - 7 of 7 Posts
Top