Halloween Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
Decided to test out my fog machines tonight. They worked fine except one ground fogger I bought from Party City about 4 years ago. It works great for the first cycle, then gradually the fog output becomes lighter and lighter until you can barely see it. Anyone ever experience a problem like this? Is it fixable or am I doomed to have to get a new one?
 

·
Registered
Joined
·
124 Posts
It is possible your pump has gone bad while sitting around since last year, but by the symptoms described, it still sounds like you have a partial clog in the line somewhere.

If you feel up for it, there is some good reference material out there for disassembling fog machine pumps. Here is a good one that points out one of the biggest trouble areas for clogs:
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #5 ·
Hey, thanks for the link! That's very helpful, maybe ill give this a shot. If it is just a simple clog, do you think shooting some compressed air down the line might clear it out? I'm not confident in my ability to put the pump back together after taking it apart like this guy. But, I guess on the other hand, two things will happen. I'll either ruin it beyond repair and have to get another one, which will happen anyway, or ill fix it for at least one more Halloween.
 

·
black light queen
Joined
·
2,639 Posts
yeah, if the pump died it's probably not cost effective to fix :-(

over the years i've discovered that some/all of the cheap fog juices tended to form some sort of precipitate that clogs the suction in the container that holds the juice ... it may be that some of that insoluble gunk got into the pump and "jammed" it? ...

amk
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top