Halloween Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I recently purchased a Helga the fortune teller MR124150 off a local for sale forum. The prop is complete but the previous owner removed the plug in wiring pins from the circuit board to disassemble for storage. I was curious if anyone has this prop and can take a picture of the circuit board so I know how to reassemble. It seems pretty simple, speaker wires goes to speaker terminal but I'm not sure which way the plug goes on to verify correct polarity or all the pins. Same for the other pins as well. When I apply the power pin to the board, assuming red is + and black is -. The circuit board has a black circle in the middle. Not sure if this is paint or what, definitely OEM. It gets SUPER hot with power applied, I haven't gotten the prop to move or lights to work yet. I'm scared the black spot getting hot is bad.

I can post a picture if available. I don't want to break any forum rules. Thank you for the help. I have tried contacting various sales places and other routes without any contact back.
 

·
Typical Ghoul Next Door
Joined
·
7,520 Posts
Hope one of our experts sees this so they can help you out!

Also hope you didn't pay too much for a non-working prop that you couldn't test even. The seller saying the actual circuit board was disconnected for storage is... odd and not at all standard. The prop should come able to be assembled and disassembled and always able to plug in after assembling and work.
 
1 - 2 of 2 Posts
Top